Home Forums Pebble App (Beta) RaceQs on Vivoactive HR

  • Creator
  • #415869

    Does anyone have experience with Garmin Vivoactive HR? I have installed the app on the watch, I am following the steps in the user guide, but after acquiring GPS signal at the timer screen, there is no swipe down available on the watch, as indicated in the guide!?! How to go further?

  • Author
  • #476336

    Hi Jonathan,

    When I look at your account in raceQs, I don’t see an uploaded marks file, which would explain why you’re not getting them loaded into your watch.

    I don’t understand why you say “… they are saved (automatically) ..”, as there is no automatic saving of marks for the watch app. You have to go the your home page on the raceQs web site and use the “My Marks” option from the dropdown menu next to your name (at the top right corner) and follow the upload instructions.

    I could not see the screen shot as it has not been saved due to an error in the Forum code which I will report to the developers.

    If you still experience problems, please email me directly with screen shots a smithalan{at}bigpond{dot}com (replacing {at} with @and  {dot} with . )



    When timer counts down I press the right button to synchronize timer to the nearest whole minute, bat the message “Sync clock by xx seconds   yes/now” appears. What does it means, and how to synchronize the timer?


    Respond “Yes” to the prompt  and it will do what you want!

    (syncs to the whole minute nearest to the time you pressed the right button)

    The message simply tells you how many seconds it’s going to sync by.

    Try it at home!


    Dear Alan!

    Thank you for promt presponce.

    In fact what I have: I press “yes” and the timer time is increased by the xx seconds showing at ” Sync clock by xx seconds”.

    Then timer continues to count down from the increased value. It’s something wrong…isn’t it?



    It’s O’K, understood!


    Hi Alan, I’ve installed raceQs on VA-HR just a couple of weeks ago.
    And I get the iQ! crash twice always after aprox. 1h30 of use. That’s happened in all training on water , just 2 til now.

    Good news, data stay stored and valid even after the crash. Anyway, seem costant. Is there any fix or walkaround? On facebook page, somebody claimed that is a Garmin OS problem and it will be fixed. News about that?

    My Garmin OS ver. 4.40

    App Log:

    ERROR: Out Of Memory Error
    DETAILS: Failed invoking
    STORE_ID: d76bf3e20924470eb86b62f372ecc0ae
    @PC = 0x100084c8
    @PC = 0x1000782f

    ERROR: Out Of Memory Error
    DETAILS: Failed invoking
    STORE_ID: d76bf3e20924470eb86b62f372ecc0ae
    @PC = 0x1000914a
    @PC = 0x1000782f



    For the records (seem that this forum is died …):

    Got another iQ! error.

    After 1:15 min approx. But this time the error LOG is quite different:


    2337 (vivoactive HR) SW ver: 400

    Build Type: RELEASE


    ESN: 3963403303

    05/03/18 19:38:49


    errnum: 0x012

    r0: 0x2005cd58

    r1: 0x20065e30

    Stack frame PC, SP: 0x00006131, 0x2005cc08

    Call Stack – SP at 0x2005cc08:

































    Uptime: 6245964



    …seem that this forum is died … Yes it is quiet, possibly everyone is happy???

    And yes, that’s a very strange error log. Are you sure you’re sending CIQ_LOG.txt?

    Unfortunately there’s nothing we can do about the crash after 1 hr. We can’t replicate it in the lab and we really think it’s a bug in the Garmin firmware.



    Hi Alan, tks for your reply.
    Well, very quiet… almost lost my hope to get an answer!
    But I hope everyone is really happy! :-)

    You are right those comes from the root log … or whatever is its name. Sorry.
    Anyway today 3 more hours in the water and 2 more errors, here, this time from the right log.
    Quite the same error twice.

    ERROR: Out Of Memory Error
    DETAILS: Failed invoking <symbol>
    STORE_ID: d76bf3e20924470eb86b62f372ecc0ae
    @PC = 0x1000914a
    @PC = 0x1000782f

    ERROR: Out Of Memory Error
    DETAILS: Failed invoking <symbol>
    STORE_ID: d76bf3e20924470eb86b62f372ecc0ae
    @PC = 0x10008191
    @PC = 0x10008ff9
    @PC = 0x1000782f

    Anyway, without consider the 1-hour time limit, well, yes. I’m very happy too with your app.
    After 85 miles sailed, well, you, lab guys, are genius, especially considering that the app take just some Kb.

    You can find attached my CIQ_LOG. Always the same error, out of memory, as you surely know. If I can help in any other way, please, count on me.

    Let me ask you, is it possible to lock the screen auto scroll beyond the 2 min limit? During training session, when there are no marks, what really count is speed, bearing and tack analysis. Onboard a small monotype, in a strong wind, wet hands etc. is not so simple to tap on the right screen each 2 min.
    One more (well a suggestion more than a question …), why the iOS or Android apps do not have all the functions available into the Garmin? At the end of the story a cell phone has a good GPS onboard and the screen is BIGGER (I’m 55 years old and the fonts onto the Garmin are sooo  little for my tired eyes…). Not considering a ton of infos that can be displayed, is independent from Apple or Garmin swatches hardware/firmware, no prog length limit, lot of people that will not invest in an expensive swatch just because are sailors will probably invest in an app. At that end, there are no reasons for a free app. Sell it. I’m sure you gonna get a lot of customers! Is simply the best app out there. And certainly is gonna be cheaper than the swatch itself! Just a curiosity …


    Yup, that’s the error that we think comes from the firmware, for which we have no fix.  


    My reply was interrupted, sorry.

    The training doc explains how you can stop the screen scrolling:


    How to stop the dashboard screens scrolling?

    This feature is provided to assist in the wet when the touch screen doesn’t work well, to provide you with access to all the screens without any touching.

    It kicks in after detecting no user input for 2 minutes.

    This feature can be disabled with a long press (touch and hold for 2 seconds) on any dashboard screen, and can be re-enabled with the same long press.

    It is disabled for the 2 minutes after detecting a user input.

    We initially went for a phone solution, but they’re mostly not waterproof, the screens are hard to read through salt-encrusted sunnies and and the downside of losing it overboard prompted us to go for a watch solution. (As a fellow wrinkly!) I sympathise with your comments about the screen size. It would be a huge task to retrofit the watch functionality to the iPhone and Android platform, so that’s unlikely.

    And yes, we’re certainly looking to commercialise the app, once we can get it out there and demonstrate its features.




    Hi Alan,
    Here we go again, with some good news.
    Today is holyday in the country where I’m living, so we went to sail. 3 hours and 10 min aprox., using my VA as usual (and the iPhone Qs tracking as well, just to be sure). We are training for the Snipe State championship, so was a long and tricky training in medium to low wind.

    The good news is that Vivoactive worked without the IQ! error for the whole time, like a sharm, and the session was quite long with a lot of tacks, as you can see in my Race Feed or in My Journal.

    The ONLY difference between this training and all the previous, and maybe (I say maybe) this look like a possible walkaround, is that I’ve stopped the watch screen cycle on the speed screen after 4/5 minutes of sailing. And there it stay until the end er … Well beyond the end, because I’ve simply forget to turn rQs off and the VA recorded a good 60 minutes beyond the finish line.

    I know, this can be due to a lucky day, but in the next weekend I gonna sail the Snipe as well as the Delta 34 and I’m very very curious to try again, stopping the screen auto scroll, and see what’s happen. Dunno nothing about Garmin OS or your gold piece of soft, but to me make sense. If auto scroll involve buffer (and I suspect yes) the out of memory error after a long period make sense as well.

    Just my 5 cents … I will keep you informed, if you want.



    Replaying to myself.
    Just 2 real water training done after my last mex but, yes, stopping the dashboards screen scroll appear to be a walkaround to the iQ! error. For me at least.
    None of 2 cases the Vivoactive HR has returned the error after well beyond respectively 3 and 2 hours of continuous use.
    Forum guys, give it a try and send a feedback.
    Maybe we can help Alan.



    I have tried to post on this forum but it requests a “Captcha” that I cannot see.

    I am trying again.



    Aha It seems to work OK now.

    I am having problems logging in with a Vivoactive HR watch. As this is now working I will try again :-)

You must be logged in to reply to this topic. or