Home Forums GeoVids Wrong date used from video file metadata for Geovids

  • Creator
  • #182647

    I have finally managed to get GeoVids to work in Chrome but not in Firefox.

    However, while the list of video files is shown in the list I get the message “We’ve found some videos, but none of them appear to be from this race”

    This is because the date is shown as 1981-01-29 01:53:22 in GeoVids

    None of the icons below the file list are active – which I presume are to allow you to shift the date/time.

    So I re-checked the camera and the date and time on it is show correctly.

    I then used ExifTool (with ExifTool GUI if you want a graphical interface) to look at the values that were being stored in the file metadata which I exported and have attached.

    This includes the correct date values:

    FileModifyDate                  : 2015:02:07 15:59:00+11:00
    FileAccessDate                  : 2015:02:08 13:10:23+11:00
    FileCreateDate                  : 2015:02:07 15:30:26+11:00

    But it also includes the fields which GeoVids is using which I cannot change in my camera as I presume it’s set in the firmware.

    CreateDate                      : 1981:01:29 01:53:22
    ModifyDate                      : 1981:01:29 01:53:22

    MediaCreateDate                 : 1981:01:29 01:53:22
    MediaModifyDate                 : 1981:01:29 01:53:22

    TrackCreateDate                 : 1981:01:29 01:53:22
    TrackModifyDate                 : 1981:01:29 01:53:22

    I cannot edit these values in ExifTool – and I cannot change them in the camera.

    I also checked MP4 files from other sources and the incorrect values above are often 0’s (zero).

    Instead of using the metadata to decide what videos to play, would it not be better to allow the user to select which videos are to play (and their order) and then have a jog-wheel (or similar UI) to be able to change the replay time to allow the user to sync the time?

    You must be logged in to view attached files.
  • Author
  • #183443

    I’m having a similar problem, but the date on the files is listed correctly. I still get the same error: “We’ve found some videos, but none of them appear to be from this race”

    My GPS data starts at 12:59:49 and my first video starts at 13:02:34

    time duration url
    2015-02-21 13:02:34 1046 F:\GoPro\2015\2015-02-21\GOPR0572.MP4
    2015-02-21 13:20:01 683 F:\GoPro\2015\2015-02-21\GP010572.MP4
    2015-02-21 13:44:15 1046 F:\GoPro\2015\2015-02-21\GOPR0573.MP4
    2015-02-21 14:01:42 1046 F:\GoPro\2015\2015-02-21\GP010573.MP4
    2015-02-21 14:19:08 1046 F:\GoPro\2015\2015-02-21\GP020573.MP4
    2015-02-21 14:36:34 55 F:\GoPro\2015\2015-02-21\GP030573.MP4
    2015-02-21 14:38:53 1046 F:\GoPro\2015\2015-02-21\GOPR0574.MP4
    2015-02-21 14:56:20 595 F:\GoPro\2015\2015-02-21\GP010574.MP4

    Would be nice if this could be overwritten by a user selection.


    According to the API documentation here, it should be possible to select a list of videos to play.



    After playing with it more I noticed it will give this message until the time in the GPS data matches some time in a video.  Then the list of videos goes away and one starts playing.  Thanks for the API link.  Trying to get this figured out.  Good luck.


    I think the API calls depend on the way RaceQs have implemented the code – it would need reworking by them and the UI changing accordingly so you can select which files to play and then manually adjust the time.


    Hi Guys,

    I have found a fix for this issue.

    I have a Garmin VIRB and I joined all my files together and output the metrics to the video. I output in low res so that it would play nicely in 3D.

    The problem is the Created/Encoded/Tagged Date – they all need to be modified to suit your race start time/GPS start time.

    The only tool I have found to do this is ffmpeg which is a command line tool.


    The script to modify the dates is this:

    Change this date time to suit –  creation_time=”2016-02-24 05:49:17″

    “C:\DIRECTORY OF WHERE YOU DOWNLOADED THE FFMPEG TO\ffmpeg.exe” -i “C:\DIRECTORY OF WHERE YOU PUT YOUR FILE\YOUR_FILE.mp4″ -c copy -map 0 -metadata creation_time=”2016-02-24 05:49:17″ “C:\DIRECTORY OF WHERE YOUR NEW FILE WILL BE\NEW_FILE.mp4″

    NOTE my start was at 17:50 but the ffmpeg converted it to am!

    I specified 05:49:17 and it converted it to pm! Must be a bug.

    It worked in Firefox and I have video with all the Garmin GPS Metrics on screen in 3D.




    You must be logged in to view attached files.

    Any hints on how you got it working with Chrome?  I’m assuming using an older version of chrome that allows npapi?  I tried using http://www.slimjet.com/ but it doesn’t seem to load the extension.

    I love this feature.  Any suggestions would be welcome.


    Hi Darin

    I found the only way I could get it to load a video was to only have one video file in the video directory.


    Weta #325, Sydney

You must be logged in to reply to this topic. or