Home Forums Pebble App (Beta) Timer Reset seems to be broken

  • Creator
  • #283140

    Just for background, I don’t use the Perfect Start functionality.  I like the timer and the dashboard.  If I get comfortable with those two, I’ll likely start pinging the start and the course.

    However, I have had limited success with just the timer.  I’ve used it for 4 races, and it has only worked half the time.  Last night was not one of the successes.

    I like to make a practice run at the line a bit before our start.  So,  I reduced the raceqs timer to 3 minutes and clicked start.  It then went into compass calibration mode.  OK.. after a 20 seconds or so, it then asked to ping the wind.  OK.  Then it hung.  So, I backed all the way out and came back in.  The timer was reset to 5 minutes.  I backed out again and opened it again, and it was counting down correctly.  It worked throughout my practice start.  I then click reset, which seemed to work.  However, it wouldnt budge from 5 minutes on the timer.  I finally had to close the app and open the crappy timer that comes with pebble.

    I did open the dashboard later, and that worked like a charm for speed and heading.

    BTW, I just love this concept, and I have personally converted two other sailors who have recently purchased pebbles for this.  Also, I am a software developer who does web and mobile.  I’d like to help in any way possible.

  • Author
  • #283515

    Hi Darin,

    A good post, thanks. Here are a few notes and questions for clarification.

    The reason it went into compass calibration mode after you reduced the time to start to 3 minutes is that it detected that you were within 4:30 of the start without having set the wind.  It does another check at 2:30 and then, if still no wind set, at 2:30 after the start. Having an initial wind is that important for it to know your point of sailing. Once it has an initial wind, it does a pretty good job of re-calculating the wind as you work upwind.

    Why it hung in the wind screen is a worry.  You don’t say whether you attempted to set the wind at that time ( pressing the SELECT button) so I am not clear about the nature of the hang. You say you successfully backed out – just with short BACK presses?

    And the hang when you went into the real start is also a bit of a mystery.

    Can I ask you to try those steps again (off the water, but with the phone receiving a GPS signal) to see if you can replicate the problem please?

    Glad you’re enjoying the dashboard and I’m sure the folks at pebble will be delighted that we’re boosting their sales!

    As a fellow software developer, you will be familiar with the challenges of getting code to work in all environments, so you will understand the need for comprehensive error reporting.

    BTW which watch and phone are you using?





    Ok.. that’s good to know about the wind detection.  I’ll make a point to do that before starting from now on.

    I believe I had just backed out with short back presses.

    I might have it on video.  I had a chest harness while I was working on it.  I’ll post to youtube.

    Yes, I’ll try it again in a moment.

    I am using the pebble steel.


    OK.. here is my vid from the water –



    I did figure something out.  I went outside and walked around with the watch and gps running.  It started in timer mode, and said “no gps.”  It then went to compass calibration, it then asked for wind, and I backed out.  It was now stuck.  You’ll notice that when it is in this state, there is no clock displayed in the timer (see video).

    However, I started the timer at 5, reset it, and then opened the timer again.  Now the time is displayed, and I was able to change the timer.  I’m not sure if it was the fact that I backed out of the wind or if it was some other reason.


    Total test steps:

    • Start RaceQs
    • Start Pebble App
    • App starts in Timer with “No GPS Data”
    • App asks to calibrate compass
    • App asks to face wind
    • Back out of face wind.
    • Timer is stuck.
    • Restart pebble app.
    • Face wind, select ok.
    • Timer still stuck.
    • Stop pebble app.  Stop Race Qs. Restart pebble. Start pebble.  Start RaceQs.  Start Pebble app.
    • Still stuck.
    • Start perfect start. Ask to Face Wind, Set Wind.
    • Timer still stuck.
    • Update Pebble app software on phone.
    • Start raceqs
    • Start pebble app.
    • Still stuck.
    • Start Timer.
    • Reset Timer.

    Great diagnostics, thanks Darin, you have provided some good material to work on.

    It confirms  a problem which we are experiencing in our testing and are working to resolve as a top priority.

    We have an ideas of where the problem lies (inconsistency in iPhone (iOS)  HTML localStorage) , but it will take  while to nail it down.

    The fact you are getting the timer showing 5:00 but no time showing below is the fault condition that a number of users are reporting but we are having difficulty replicating “in the lab”.  If we can’t replicate, we cant fix!



You must be logged in to reply to this topic. or