Home Forums Pebble App (Beta) Beta 1.22a stuck

  • Creator
  • #448666

    I Just found that there was an update for the app available and loaded it.

    The app gets stuck at “waiting for GPS”… never gets beyond that.

    I checked the GPS signals with another watch app that shows green (good) GPS signals.

    Suggestions ?

  • Author
  • #448780

    There must be some other influence at play here – it runs fine here.

    If you haven’t done so already, could you please:

    1. uninstall raceQs from your watch.
    2. restart your watch (15 second press on both buttons
    3. download the app again
    4. ensure the watch is connected to the Garmin app on your phone with internet connection
    5. restart the app with the watch in view of the sky for GPS reception

    And let me know how it went. Sorry for the hassle.


    Hi Alan,

    The other influence seems to be whether bluetooth is connecting the watch to the phone.

    I followed the procedure you described.

    After reloading the app, and before connecting it to the garmin app on the phone I ran the app. It got stuck waiting for GPS as before. I then completed the procedure, connecting to the Garmin app on the phone etc… downloading my waypoints once again. The app worked as expected at that point.

    Once I turned off bluetooth on my phone, the app would get stuck waiting for GPS.

    I tried again… turning off bluetooth on the watch, running the app, the app stops at waiting for GPS.

    Tested again with bluetooth on and the watch showing it’s connected via bluetooth. The app works as expected.

    Disabled bluetooth on the watch again…. the app gets stuck waiting for GPS.

    The Garmin app apparently doesn’t have to be running on the phone. The app just has to find a blue tooth connection to proceed. I use my watch with bluetooth off unless I need that connection, in order to extend battery life.



    OK, I can confirm your findings: the app hangs with BT off,  This is not expected and I will have to investigate further. I’ll report back when I have it sorted. Thanks for the heads-up, I wouldn’t have detected that in my testing.



    Happy to help.

You must be logged in to reply to this topic. or