Home Forums 3d Race Replay 3D Replay no longer working using Google Plugin

  • Creator
  • #216350

    I am aware that the Google Earth plugin is being retired and that you are switching to Cesium, but while the Google Earth plugin was working in Firefox a few days ago, it now doesn’t load (I just get the spinning 3D boat).

    I don’t get any option to switch to Cecium in Firefox.

    If I load the replay in Chrome I get the same spinning boat but I also get the “Try New Version” button.

    Clicking the new version loads 20% and then freezes showing the Google Earth background but no boats or controls  – refreshing the page will usually get it to load.

    I also tried IE which also had problems with the Google Plugin that required an update that  wouldn’t install (error 1603) .

    The “Try New Version” button was available which worked successfully.

    I’m using Firefox 39.0
    Google Earth Plugin Version:
    State: Enabled

    Chrome Version 43.0.2357.132

    Internet Explorer 11

    Win 7 Pro SP1


    It might be time to switch to Cesium by default.

  • Author
  • #217022


    Thank you for your feedback.

    1. Absent “Try new version” in FF could mean that the app failed to update itself. Please, try clearing FF cache


    2. Boat spinning infinitely in GE or loading stuck at 20% in Cesium is the same issue. It has to do with server and not GE/Cesium. We are still to find the cause and fix it.

    3. In a sense we’ve switched to Cesium – it is loaded for new users by default.

You must be logged in to reply to this topic. or