Home Forums Pebble App (Beta) Beta 1.22a stuck Reply To: Beta 1.22a stuck


Hi Alan,

The other influence seems to be whether bluetooth is connecting the watch to the phone.

I followed the procedure you described.

After reloading the app, and before connecting it to the garmin app on the phone I ran the app. It got stuck waiting for GPS as before. I then completed the procedure, connecting to the Garmin app on the phone etc… downloading my waypoints once again. The app worked as expected at that point.

Once I turned off bluetooth on my phone, the app would get stuck waiting for GPS.

I tried again… turning off bluetooth on the watch, running the app, the app stops at waiting for GPS.

Tested again with bluetooth on and the watch showing it’s connected via bluetooth. The app works as expected.

Disabled bluetooth on the watch again…. the app gets stuck waiting for GPS.

The Garmin app apparently doesn’t have to be running on the phone. The app just has to find a blue tooth connection to proceed. I use my watch with bluetooth off unless I need that connection, in order to extend battery life.